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Advanced ProCite Skills: Automating Library
and Database Searching

This workshop will help participants get references from online library catalogues and databases
into ProCite databases with a minimum of fuss. From within the ProCite program, participants
will learn how to link directly to various local, national, and international library catalogues and
how to save their search results as ProCite database entries. Next, participants will learn how to
save other online database search results (such as MLA WebSPIRS) in formats that ProCite can
convert to database material. Lastly, participants will learn how to download and use third-party
configuration files that will allow ProCite to convert searches from other major databases.

What? And Why?

Often, we spend hours at the library, searching the catalogue and online databases. We
look up books, scrawl call numbers on little bits of paper, locate the book, then enter it
into our database. ProCite allows us to search (among other things) the U of A GATE
system, and to have the results (call numbers included) downloaded into a ProCite
database. On other occasions, we search online databases, email the results to
ourselves, and print them. These records are then manually entered into ProCite
databases. However, ProCite 5 is very good at translating these email text files directly
into database records, no retyping necessary. Even if ProCite itself doesn’t have a
built-in converter for your particular database, you can usually find third-party
converters (called configuration files) on the web to do the job for you.

Using ProCite to Search Online Library Catalogues

From Start > Programs > ProCite 5 > ProCite 5, open the program. The last-used
database will open. You will create a new database called ‘“downloads” into which you
can save your searches. To do this, choose File > New, and ‘new ProCite database’ from
the dialog box. Name the new database ‘downloads’ and save it to the desktop (N.B.
The ProCite program folder will be the default location; be sure to browse for the
desktop before saving the database).

From the menu bar, choose Tools > Internet Search: the display changes.

Note the appearance of two new menu bars:
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The first, upper bar concerns the search terms: New Search will clear all the text boxes in
the search window. New Item plops a new, blank, line in the search window. Delete
Item can delete an unused search line, although all blank lines are just ignored in a
search. Clicking Terms generates a dialog box where you can select any exiting terms
from a ProCite database that is currently open. (We won't go through this in this
workshop. If however, you'd like to do this on your own, follow these instructions:
Click in the field where you’d like the search term inserted; select the name of the
database from the “Source” drop-down list; select a category (Author, Journal etc.) from
the “Terms” drop-down list; highlight your search term and click “Insert Term.” Voila!)
Expressions allows for the saving, reuse, and editing of idiosyncratic search expressions
you might like to use over multiple sessions.

The second, lower bar indicates which remote databases (library catalogues are remote
databases) you have chosen to search. The default host is usually ‘OVID Trial Server,’
although in many U of A labs the default is set to the U of A library (The Gate).

Let’s try it. Let’s search the U of A to generate a printout of texts and call numbers to
bring to the library to find a bathtub-worthy novel to read.

First we need to choose which library to search.

1. Click ‘Hosts’.

|¥ ProCite 5 - [Internet Search]
Fil=  Edit ‘iew Sort Select Groups  Datab

= &

2] Mew Search i} Mew Item 3 Delete Item

- P @Hnsts: University of alberta: Library Cakalog

Search for : [Author =l
AND | |Title =
AND w| |Keypwords =l
(2ND =] [aryFisid =~ |
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A dialog box appears:

Internet Hosts m

All Hosts | barked Hosts |

Number of catalogues

chosen to search S

Hosts: MOURYE 0 Hosts bMarked
Host | Location |T pe  / | -
[ Wirginia Oseamonwealth University - Library Catalog USA Virginia __Academic
] University of Wisconsin-Madison - Library CW LISA Wisconsin Academic
C = E;IABRS: 5 (Nomay) - Libraty Catalog Click Title bars to sort by Host gﬁﬂmz

Center for Research Libraries - Library | name, Location, or Type Consortia
S (= R Consortia
—1.Jai + indicates - Library Catalog US4 Washington, D.C. Consortia
—[Bell| sub-libraries. ooks USA, Corporate
E-CSivg  Clice to expand LISA Corporate
LI Res — US4 California Corporate
[ University of Missouri Systerm - MERLIN (Library Catalog) USA; Missouri Corporate
EFCJOVID USA; New York Corporate
EFCCWID - Trial Server LISA; Mew York Corporate
1 SUNY-Albany - Library Catalog US4 New vork Corporate
B OCLE FirstSearch USA; Ohio Corporate
[ Nowa Scatia Provincial Librany - Library Catalog Canada; Mowa Scotia Gowvernrment
—[] Bibliotheque Mationale du Quebec- Library Catalog Canads; Quebec Gowernment
—[1LU.S. Mational Institute of Health - Library Catalog US4 Maryland Gowvernment
I New vork State Dept. of Health - Librany Catalog USA; New York Gowernrment
LS. Library of Canaress - LCYaovaoer 239.50 USA Washinoton, D.C. Gowernment ﬂ

Clear Marks I Configure Hosts
DA

De-selects all hosts

(0] I Cancel | Help |

2. Select the University of Alberta Library Catalogue by ticking the box beside its

name.

3. Click “'OK’

Next, we need to establish our search terms:

1. Fill in the appropriate fields. If you are trying to find Lady Audley’s Secret, punch
that in the Title field. If you are looking for books about gardens, type that into the
Keywords field.

2. In the boxes that all currently say “AND’ note that you can choose the other boolean
search terms ‘OR” and ‘NOT".

& Hosts: University of Alberta: Library Catalog

Database to be searched

Search for W Note the
drop-
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need. Blanks are ignored
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3. Using buttons on the upper menu bar, practice adding and deleting items, just for
fun.

4. Once you've got a good and complicated search expression, save it by pressing the
Expressions button, and selecting “Add to Expressions” from the drop down list.
Choose a name for your expression, then save it. Now, clear the search fields by
pressing the New Search button. To regain your search terms, click Expressions again:
notice your saved expression at the bottom of the drop-down list.

5. When you're satisfied with your search expression, click the Search button on the
upper menu bar.

If you've concocted your search terms well, you should have a pile of references thus:

Search far IAuthDr LI I ﬂ

lanD 2| |Title | |tody Audley's Secret

() . . ;
| Braddaon, M. E Lady Audley's secret 16-7
E Braddaon, M. E//Skilton, David Ladhy Audley's secret 1985
| Braddaon, M. E/{Taylor, Jenny Lady Audley's secret 19493
[ |Hazlewnonod, C.H//Braddon, M. E  Lacy Audley's secret an original ve 186-
| =Lee's Opera House (Frederictan, [ Lee's Opera House Tuesday eve't 16-7
| Memwell, Mary Elizabeth (Braddon) Lacy Audley's secret A novel 1863
| Fioberts, Gearge//Braddaon, M. E  Lady Audley's secret a drama in tw 18637
[
H/4|» M} Internet Search { Marked Records Search i Terms
Author/Title/Date (Ascending) |0 Records Marked |8 Records in List |8 Recards in Database
Pieady L oM

Notice that your search results are a ProCite database. Open a record; note how, for the
most part (barring librarian error) the information is in the right fields. Awesome!

These records are in a temporary database: to preserve them, you must copy them to
your “downloads” database. Select the records you wish to preserve, and then mark
them. Under the Database menu item, select ‘copy marked records” and then navigate
to your downloads database. Done!

Alternatively, you may just wish to print out your results, and you can do this from the
temporary database the same way you would from any other ProCite database.
Remember, you can include call numbers in your print out, thus eliminating the need
for all of those tiny bits of paper!
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We have searched just one library, but you can search many of them at the same time;
just select multiple hosts in the same way we selected a single host for this search.
Remember, though, the more hosts, the longer the search time. Also, the fields
available for search vary from database to database, so in a multiple host search, some
of your queries may fall on deaf disks.

(Please note: Since the release of ProCite 5, the U of A Library has changed the way that
it organizes its data. If you are using ProCite on a public workstation at U of A, your
ProCite configuration has been updated. If, however, you are using your own version
of ProCite, you will need to modify the configuration for this host. You can find the
instruction for how to do this at

http:/ /www library.ualberta.ca/subject/healthsciences/ procite /SIRSIProCiteConfig.p
df

Using ProCite to Convert Search Files into Database Records

This is the other method by which ProCite can automate the turning of your database
searches into bibliographic records. We will begin by converting records that ProCite is
already equipped to handle (in this case, records from the MLA database). First, you
will need a text file of search results. If you email results to yourself, you can cut and
paste text from the email into a notebook (Start > Programs > Accessories > Notebook),
and saving the resulting files as whatever.txt. To save time, you've already saved the
tile called searchresults.txt; we will be using this to practice on.

To convert searchresults.txt to ProCite database records:

1. From the menu bar, select Tools > Import Text File. A dialog box will pop up,
prompting you to locate the text file in question. It is on the desktop. Select the
searchresults.txt file and click “OK’

2. You will see a change in the ProCite display - see the graphic on the next page of
this handout. The main window features the text file: above this, you will need to
specify precisely what kind of database you used, what the format of the text file is,
and what database you’d like the converted records to be directed to, before the
conversion can proceed:

e File type: tagged, or delimited. Tagged files have field identifiers like AU or
TI. Delimited fields looks like word soup, and have a lot of commas,
quotations marks, and semicolons in them. So searchresults.txt is a tagged
file.

o File Format: searchresults.txt springs from an online MLA search on
SilverPlatter WinSpirs. (N.B. the name of the online database, the MLA
International Bibliography, is not necessarily the same as the format of the
database, SilverPlatter. Check for the platform of your database before you
try to convert records.) From the drop-down list, select the format
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‘SilverPlatter (SPIRS) ver 2. Every single database is different, and they often
don’t announce their format, so you may have to email for tech support. If
you get this part wrong, nothing is going to work.

|P ProCite 5 - [searchresults] !EB
| Eile Edit view Tools Window Help =R
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o Target Database: you can select this from either the drop-down menu (open
databases) of the browse button (any database at all). Let’s choose the
downloads database from the desktop.

3. Now you can click “Transfer” - this action will likely generate an attention box telling
you that there is “‘No Database Identifier Found.” For more arcane databases, you
would do well to select “use default’. However, if you now click “Choose..” you will
be able to find “MLA International Bibliography” in the selection box. Select it and
click ‘OK’

4. An attention box will inform you that 25 records have been converted, and 0
discarded. This means it all worked ©.

5. To see your new records, select Window > downloads to transfer over to that
database. Notice how there are 25 marked records in the database: these are the
converted records. If anything was marked before, it's not marked now. In any
case, click the “‘Marked Records’ tab to see only the converted records. Double-click
on some of them to see how well the information is spread across the fields.

Using Third-Party Configuration Files to Convert Data
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One of the great things about ProCite is that it allows people (even you!) to build
customized configuration files to import data from any number of sources. You can
find lots of these configuration files on the web (I've attached a list of useful web
resources at the end of this handout). However, the best approach is always to see if the
library that you are using has made custom configuration files for its own resources.
Fortunately for us, the U of A library has a number of custom configuration files
designed specifically for online databases in the U of A system. To access these
configuration files, go to
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